phpmyadmin 최신 버전으로 업데이트 하기
IT Info & Tips/리눅스 & NAS Info

phpmyadmin 최신 버전으로 업데이트 하기

현재 우분투 LTS가 14.04까지 나와있지만, 여러 이유로 여전히 본인처럼 12.02 LTS를 사용하는 이들이 많을텐데, 이럴 경우 phpmyadmin을 apt-get install로 설치시 3.x의 구버전이 설치된다. 4.x 대의 최신 버전을 설치하려면 아래의 과정을 별도로 거치면 된다. 


참고로 3.x 버전에서는 한글이 지원되지 않는다.


모든 내용은 터미널 (Ctrl+Alt+T)에서 Sudo su --> 패스워드 입력을 통해 루트 권한을 획득한 후 실행하는 것을 기준으로 한다.



apt-get install python-software-properties

add-apt-repository ppa:nijel/phpmyadmin

apt-get update

apt-get install phpmyadmin

dpkg -l phpmyadmin 



설치 중간에 dbconfig-common을 이용한 DB 업데이트 유무를 물어보면 예를 선택한다. 이후 패스워드를 물어보니 정해두고 잊어먹지 말자. 나머지는 3.x 버전대의 phpmyadmin과 동일하다.



보다 자세한 사항은 구글링 하시길. 위 내용은 본인이 기억해두고 위한것이라 필요한 사항만 남겨둔 것임.


반응형